Print Agent Ifs Cloud

  • 30 November 2022
  • 6 replies

Userlevel 3
Badge +7

Hello ,

we have a problem with the print agents, after about 1 Hour, it looks like the print agent tries to authenticate again but gets an error. I think it is trying
to authenticate through SSO


Error Message: Error loading discovery document: Endpoint belongs to different authority:


Print Agent and IFS Cloud server on premise
error message: Exception while looking for jobs.


Thank you in advance :)


IFS Aurena framework version:

IFS Aurena client version:

IFS OData provider version:

6 replies

Userlevel 7
Badge +25

Hi @jzouaoui,

This looks more like a connection issue between the Middle Tier host and the Print Agent host. Do you have the Print Agent installed on the Windows Management Server or a separate utility server? If it is on a separate server, check whether there are any connectivity issues between the servers. You could also try to install a Print Agent on the Windows Management Server to see if you still get the same error. 

Please also upload the Print Agent log file that contains the full error.

Hope this helps!

Userlevel 3
Badge +7

Hello Charith  ,


1) the print agent is already install on the Windows Mgt server

2) When we stop and restart the print agent, it works for another hour.

Attached the  Print agent Log.

thank you :) 

Userlevel 3
Badge +7

@Charith Epitawatta can you help please :) 

Userlevel 7
Badge +18

Hi @jzouaoui ,


This has been identified as a bug in the IFS Print agent has been fixed in 22R2 Service Update 6




Userlevel 5
Badge +11

latest update


IFS Fixed Version: 21.2.19 - 21R2 SU19, 22.1.14 - 22R1 SU14, 22.2.7 - 22R2 SU7, 23.1.0 - 23R1 GA, 23.2E.0 - 23R2 EA



Userlevel 5
Badge +13

Hi @Shanaka Tennakoon 


Do we have any workaround for this error? In DEFAULT Report Print Task Template it isn’t easy to map logical printer to physical one due to printer drivers.