Install IFS Cloud 22R1 behind a proxy | IFS Community

Install IFS Cloud 22R1 behind a proxy

  • 17 June 2022
  • 1 reply

Userlevel 5
Badge +9
  • Sidekick (Employee)
  • 44 replies

Hi, currently we are installing IFS Cloud 22R1 on customer envrioment.

(before what we installed twice in IFS internal server and eveyhting works fine.)


sicne our customer use proxy,

 to access internet, we did the proxy setting on both Managment Server and MiddleTier Server.

accourding to this doc:


While, still we encounter an error , when run :

.\installer.cmd --set action=mtinstaller --values ifscloud-values.yaml --values solutionset.yaml 


 for all ifscould namespace Pods, there is only one container inside

 the “linkerd-proxy” container is missing


we already added the POD IP , Service Cluster IP ,Local Server IP to NO_Proxy.

vim /etc/environment


HTTPS_PROXY=<customer’s proxy>

HTTP_PROXY=<customer’s proxy>

NO_PROXY=,,, → pods range→ service cluster ip → customer lcoal network and default pods range


is there anyone encouner the same error?


Best answer by Shou 23 June 2022, 13:59

View original

1 reply

Userlevel 5
Badge +9

Just fixed the error , and let me summarize it.

1 - for Middle Tier Server, 

      do what exactly desribed in IFS doc:


2 - for Managment Server:

     set the following  enviorment varible:



         NO_PROXY=, <local ip>

   ※otherwise will get error on helm 


3 - even do the above, we still get error at

      .\installer.cmd --set action=mtinstaller 

      ※only 1 container in ifs-cloud’s POD,  the linkerd-proxy NOT get injected.

      to fix this , we have to

      1)  run   “ .\installer.cmd --set action=mtinstaller ” anyway, and wait for all pods be “running” status

          (to make all pod’s images are downloaded and cache at microk8s )


      2) go to middle server

          comment all proxy setting at /etc/environment 

          then reboot.


       3) go back to Managment Server ,

            run command to

               “action=delete” middle tier , then

                “action=mtinstaller” to install it again

               ※because all images are cached at microk8s,  you don’t need internet(proxy) this time. 


         Then I get everhing okay.


           after then , even I  roll back the  proxy setting at /etc/environment , then restart server, everything still works fine.


         Hope this helps.