BPA ETag error: what is the matter?

Userlevel 7
Badge +18

I have started of with a rather simple workflow and kept expanding it. Until I hit an error that I just can't put my finger on. When using the flow in the place where it should be triggered, I now get an error: “ETag is incorrect”.

I've noticed that ETag is shown at the elements, at least most of them, in the bottom. The help text on ETag goes along the line that one can override it so the flow continues. I've left the override ETag to the default of unchecked. I got the mentioned error message. For a couple of elements that I've been adding lately, I have also tried to use the Override ETag option and turned it on. After deployment I still get the error that the ETag is incorrect.

Next was to turn on the network debug of Bing (yes, I did the same in Chrome) and it gives me the following error:

Still no clue in this one for me. I understand, that something is wrong. I see that something is not working correctly for the projection SalesQuotationHandling (this is set up in the Projection Action Information of the workflow). Workflow Timing has been set to Before.

No Event Action Information has been added.

I'm not a developer, so can't get to the database to maybe get a closer look (although I don't think that would help me).

ORA-20110 is a global catch for any error as far as I understand, so that doesn't help me.

Does anyone have an idea what the error ETAG_INCORRECT means?


4 replies


I had the same problem 


Get_Objid_From_Etag___(etag_) return null 

So that is the case for IFS Support

Userlevel 7
Badge +18

@szambur I don't have access to the svc packages, but being a former PL/SQL api builder, I have no problems reading and understanding what you/the systems mean.

Thanks for sharing this information/screenshot. Now back to the drawing/workflow board to get the objid_ in place.


Ok in my case was helped



Userlevel 7
Badge +18

@szambur Thanks for the detailed information. I have to check this against the workflow. When a workflow runs into an error, it doesn't say at what task/activity. So this will take me some time to check it.