Question

APPS8 - The request was aborted: Could not create SSL/TLS secure channel - Enable HTTPS


Userlevel 2
Badge +6

Hi guys,

 

a customer wants to activate HTTPS on their APPS8 SP2 environment.

Therefore I tried to enable it on our internal DEV environment.

 

What I did:

 

1. Reconfigure with Self signed certificate using Port 8080 for HTTPS
2. Access URL with Port 8080 and download the Public Certificate http://wis.ifsworld.com/f1docs/apps8/foundation1/040_installation/500_references/060_oracle_ssl_configuration/
3. Installed Public Certificate in Oracle Wallet
4. I installed Public Certificate as Root CA Certificate on Client Host - The HTTPS website can now be opened without error
5. Update PLSQL_ENVIRONMENT_TAB INSERT INTO plsqlap_environment_tab (NAME,VALUE) VALUES ('SSL_WALLET_PATH','file:D:\ORACLE\Admin\S11549\wallet'); INSERT INTO plsqlap_environment_tab (NAME,VALUE) VALUES ('SSL_WALLET_PASSWORD','ifsmanagerS11549');
6. Check if IFSPLSQLAP can login to IFS - possible
7. Login and load some data - If there are DLL files needed it will download them and crash when done. If the files are already present data can be loaded. Sometimes already loaded application form throw and SSL/TLS error which leads to a crash.

Is there anything I was missing?

Do you have some custom manuals which you have used?

Thanks for any information of your experience!

 

EDIT: Some additional info: This APPS8 environment was initially set up with APPS8 SP1 and then upgraded to SP2 with Weblogic Server.

 

Regards

Bernd


18 replies

Userlevel 6
Badge +10

Hi @Bernd Osterkamp 

Did you do a restart of database and Application Server after the changes has been done in the system?

Userlevel 2
Badge +6

Hi @Ragaventhan Sathananda 

Yes I did and I now retested it.

The current situation, the most times is, that I can now load Assemblies and when I try to load data, sometimes it works sometimes it gives me the error “Could not create SSL/TLS secure channel”

Userlevel 2
Badge +6
Stuck when loading assemblies. Even after 15 minutes form Sales Part cannot be opened
​​​​​​

 

Userlevel 2
Badge +6
Restarting Apps will enable the previous form to load without error (Sales Part)

 

Userlevel 2
Badge +6
Data can be loaded in form Sales Part

 

Userlevel 2
Badge +6
Changing to form Inventory Part result in error: Could not create SSL/TLS secure channel
Sales Part form isn’t available as well after getting this error

 

Userlevel 2
Badge +6
Because of the missing connection the profile can’t be saved when restarting Apps

 

Userlevel 2
Badge +6

After restarting I can load form Sales Part and also Inventory Part without error and can load data in these forms. Even scrolling through all the data is possible without error. Only switching to other forms will cause the error after a random time. 

Userlevel 6
Badge +10

Hi @Bernd Osterkamp 

Could you please run the below commands;

  • EXEC Prepare_SYS.Dbagrant(‘<appowner’s username>’);
    commit;
  • As AppOwner e.g. ifsapp,
    BEGIN
    Installation_SYS.Grant_Ifssys(TRUE);
    commit;
    END;

After running the above command please do a database restart and do a application server reconfiguration. After application server re-configuration and database restart, verify that PL/SQL Access provider icon turns to green color indicating that the settings are correctly applied:
 

  1. Open IFS Applications and navigate to:
    Solution ManageràMonitoringàApplication Monitoring
  2. Open Application Monitoring Console and locate PL/SQL Access Provider Group

     

Userlevel 6
Badge +10

Hi @Bernd Osterkamp 

In addition to the above you may check the below post as well for further advice on it.
 

 

Userlevel 2
Badge +6
  1. EXEC Prepare_SYS.Dbagrant(‘<appowner’s username>’);
    commit;

    DONE
  1. BEGIN
    Installation_SYS.Grant_Ifssys(TRUE);
    commit;
    END;

    DONE
     
  2. Restart MWS and DBS

    DONE
     
  3. Checked PLSQL Access Provider Ping

    DONE - failed
     


    http://dse1vmpe41.corpnet.ifsworld.com:58080/

    https://dse1vmpe41.corpnet.ifsworld.com:8080/

    Login with ifsplsqlap is possible

    My HTTPS connection installer configuration

     

    The below settings Cipher suite and Protocol are working better than the original default settings.

     

Userlevel 2
Badge +6


Left BNT, right DEV environment

Userlevel 2
Badge +6

 

 

Userlevel 2
Badge +6

 

\\LKPDB114\S11549_wallet

Userlevel 2
Badge +6

When the connection starts interupting after several forms and data loads the HTTP log throws:
 

[2021-07-16T16:13:36.6899+02:00] [ohs] [ERROR:32] [OHS-2079] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2024] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  nzos handshake error, nzos_Handshake returned 28862(server dse1vmpe41.corpnet.ifsworld.com:443, client fe80::5cca:57e1:dc98:cda7)

[2021-07-16T16:13:36.6899+02:00] [ohs] [ERROR:32] [OHS-2171] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2024] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  NZ Library Error: SSL IO error [Hint: the client stop the connection unexpectedly]

[2021-07-16T16:13:41.9619+02:00] [ohs] [ERROR:32] [OHS-2079] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  nzos handshake error, nzos_Handshake returned 28862(server dse1vmpe41.corpnet.ifsworld.com:443, client fe80::5cca:57e1:dc98:cda7)

[2021-07-16T16:13:41.9619+02:00] [ohs] [ERROR:32] [OHS-2171] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  NZ Library Error: SSL IO error [Hint: the client stop the connection unexpectedly]

[2021-07-16T16:13:43.2431+02:00] [ohs] [ERROR:32] [OHS-2079] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  nzos handshake error, nzos_Handshake returned 28862(server dse1vmpe41.corpnet.ifsworld.com:443, client fe80::5cca:57e1:dc98:cda7)

[2021-07-16T16:13:43.2431+02:00] [ohs] [ERROR:32] [OHS-2171] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  NZ Library Error: SSL IO error [Hint: the client stop the connection unexpectedly]

Userlevel 6
Badge +10

When the connection starts interupting after several forms and data loads the HTTP log throws:
 

[2021-07-16T16:13:36.6899+02:00] [ohs] [ERROR:32] [OHS-2079] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2024] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  nzos handshake error, nzos_Handshake returned 28862(server dse1vmpe41.corpnet.ifsworld.com:443, client fe80::5cca:57e1:dc98:cda7)

[2021-07-16T16:13:36.6899+02:00] [ohs] [ERROR:32] [OHS-2171] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2024] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  NZ Library Error: SSL IO error [Hint: the client stop the connection unexpectedly]

[2021-07-16T16:13:41.9619+02:00] [ohs] [ERROR:32] [OHS-2079] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  nzos handshake error, nzos_Handshake returned 28862(server dse1vmpe41.corpnet.ifsworld.com:443, client fe80::5cca:57e1:dc98:cda7)

[2021-07-16T16:13:41.9619+02:00] [ohs] [ERROR:32] [OHS-2171] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  NZ Library Error: SSL IO error [Hint: the client stop the connection unexpectedly]

[2021-07-16T16:13:43.2431+02:00] [ohs] [ERROR:32] [OHS-2079] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  nzos handshake error, nzos_Handshake returned 28862(server dse1vmpe41.corpnet.ifsworld.com:443, client fe80::5cca:57e1:dc98:cda7)

[2021-07-16T16:13:43.2431+02:00] [ohs] [ERROR:32] [OHS-2171] [http_core.c] [host_id: dse1vmpe41] [host_addr: 10.1.117.135] [pid: 8360] [tid: 2092] [user: SYSTEM] [VirtualHost: dse1vmpe41.corpnet.ifsworld.com:0]  NZ Library Error: SSL IO error [Hint: the client stop the connection unexpectedly]

Could you please share the HTTP server and node manager log when this error pops up on the system?

Userlevel 2
Badge +6

Here are the log files.

Userlevel 6
Badge +10

Hi @Bernd Osterkamp 

It will be better if you could log a case to IFS. So that we can come through a screen sharing session and resolve the issue.

Reply