Error when uploading an Image  to an external supplier invoice

  • 17 March 2023
  • 6 replies

Userlevel 1
Badge +7

I am trying to upload an Image (pdf)  to an external supplier invoice by following the below steps listed under  ReceiveEinvoiceService API Documentation, but Postman  raise  ‘UNSUPPORTED_FORMAT”  error.

Noticed quite a few community entries suggesting checking parameters by processing same  action through Aurena Application.  

Is there any Page in  the IFS Application where it possible to attach an Image to an Invoice ?

What are the correct parameters that should be passed when calling ReceiveEinvoiceAttachmentSet ?

Tried in 22.2.5   and 22.1.5 cloud Environments   and experienced the same issue.

Any tips to avoid that error is much appreciated.




Best answer by Thomas Peterson 20 March 2023, 15:32

View original

6 replies

Userlevel 1
Badge +7

Thank you  gumabs and  Thomas Peterson for your tips.

I found why I am getting that error finally.


 Error has been raised as I was calling Request Method without the ‘/Attachment’ part.

The Request went without Error when I call it as below. 



Userlevel 7
Badge +18


It would be interesting to see if you can “manually” enter an image on the posting proposal. Use the same doc class as would be used on the external supplier invoice flow.   

A common screen for supplier invoice is posting proposal. 

Hypothetically, if you have document class / document management set up issues, the manual process of attaching an image will fail as well. If the manual process works, then the issue is probably not caused by document management basic data. 

The ability to attach objects within an IFS screen is configurable - see the objects connections page.  This lists the screen, other data, and what objects can be connected to that screen. 

For example - the sales part screen - you can see allows Documents as the only object connection - attachments. 

Typically posting proposal would be already configured to allow attachments.

Best regards

Userlevel 1
Badge +7

Thanks for your reply, File Type do exist in the “Document File Type” Page.

Userlevel 7
Badge +19

Hi @bhraau 

Add in this window your file type and try again.



Userlevel 1
Badge +7


Userlevel 1
Badge +7

 Parameters used on Patch request:



filename=Base64Encoded file name  value .

Tried with and without extension, same Error.

Tried with different extensions, same error.



Also tried with the E-Tag value by feting it using GET , no change