Question

FSM6u10 Customer Portal Attachments

  • 23 September 2021
  • 2 replies
  • 27 views

Userlevel 3
Badge +8

We have an issue on the Customer Portal where we can see thumbnails of image attachments, but cant retrieve the actual file (or any file attachment type for that matter), it seems to lock up for a while then get an error when trying to open it. I am assuming that it can ‘read’ the file (or at least the thumbs.db in that folder) for it to be able to show the Thumbnail, or does it produce a Thumbnail via another method.  I am trying to understand why it can retrieve a thumbnail but not the actual file?


2 replies

Userlevel 3
Badge +8

@Ruchira Jayasinghe

 

Thanks for the response. We have now discovered however that it is not attachments that were causing our original issue.  We had an error popup (timeout) and initially thought that it was the attachments not loading, but it is acutally the code that displayes the created date on the page for the Notes, we have 64 notes on the particular request. If we remove the code that subscribes the created_dttm field on the form then the request appears without issue and all the attachments load a lot more quickly

Userlevel 4
Badge +4

Dear @MartinF,

 

I tested the reported situation in FSM 6 upd 10 environment, by uploading 3 files (image / doc / zip) to a request via Customer Portal itself and 2 more images files from Web Client and Smart Client. Those files got listed in the Customer Portal and the thumbnails were displayed as expected.

 

 

When the same was checked via the DevTools – Network, we could see those files were received by the Client end successfully.

 

 

When you click on the thumbnail, nothing will happen. If I am not mistaken, that is the expected behavior.

But, when you click on the link (the name of the attachment), the file will get downloaded without any problem. I cross-checked the size and it is also matching to the originally uploaded one.

 

Further, when I inspected the elements of the web page, I noticed that, those Attachment Name are bound to the base64 codes of the attachments.

 

 

You can manually download the file using the link (href) code as well.

 

Hope this information will help you to understand the issue and investigate further if required.

Reply