FSM Web Client search screens show a default of 10 records | IFS Community
Question

FSM Web Client search screens show a default of 10 records

  • 17 February 2021
  • 7 replies
  • 142 views

Userlevel 5
Badge +14
  • Superhero (Employee)
  • 136 replies

The FSM web client shows by default 10 records at a time.

How can we change this default number, either per screen or globally?


This topic has been closed for comments

7 replies

Userlevel 6
Badge +16

Hi @nickz,

 

In web client, you can select below drop down in the bottom of the screen and select the default rows to be populated for that screen.

 

Then you can save the screen settings. So selected value will be defaulted to selected screen. Hope this helps. Thank you.

 

Kind Regards,

Kalpani

Userlevel 5
Badge +14

thanks when I hit ‘screen setting’ and save I get this error though.  Do you know which table I need to tidy up?

 

Userlevel 6
Badge +16

Hi @nickz,

 

It may cause if you try to use the same primary key multiple times. But for the clarification, could you please let me know the steps you have followed? Because it displays as screen setting saved as well.

 

Kind Regards,

Kalpani

Userlevel 5
Badge +14
  1. I logged in
  2. opened the Request screen
  3. changed the default from 10 to 50
  4. used the ‘screen setting’ option from the [?] option at the top of the screen
  5. hit save
  6. both messages appear.

I’ve logged out, now I’m logging back in and try to access the request screen (web client again) I get this error:  (I can’t even access the request any more :-( ).  FRom my smart client if I clear the Request screen settings, it makes no difference to my web client….it still errors in the same way.

 

Userlevel 6
Badge +13

A Suggestion:
Issue could be that more entries from the same column in the Requests result list view, which can caused this error. If such exist then remove one of them then it should work.

Userlevel 2
Badge +4

(FSM 6.8 Web Client)

 

You can change this for a particular custom screen from the initial_page_size of the list_group.and it does display accurately on the web client when using the predefined stops of 10,25,50,100.

 

Example XML for a custom Request screen in UI Designer:

 

<request>

...

(result/add-edit)

...

<list_group>

...           <initial_page_size>100</initial_page_size>

 

Not sure about “All” -- it’s not 0 or -1 but have not played with the metadata for cs_group.initial_page_size. . :)

Userlevel 3
Badge +7
  1. I logged in
  2. opened the Request screen
  3. changed the default from 10 to 50
  4. used the ‘screen setting’ option from the [?] option at the top of the screen
  5. hit save
  6. both messages appear.

I’ve logged out, now I’m logging back in and try to access the request screen (web client again) I get this error:  (I can’t even access the request any more :-( ).  FRom my smart client if I clear the Request screen settings, it makes no difference to my web client….it still errors in the same way.

 

Dear all,

we have the same issue now for our configured screen. Is there already a standard approach / a suggested solution to sort that out?

regards,
Thomas