Custom Item Forms Created in v11.4 Don't Show Correctly in v11.5

  • 4 October 2022
  • 3 replies

I created some custom item forms in v11.4.3, applied the necessary visibility requirements, and associated the form with the required Product Class value.  However, since I upgraded our test environment to v11.5.1 the majority of the fields in the custom forms don’t show, even though they are not hidden or discontinued.  If I remove the custom form association then the default Item form details are all shown.  I also tried creating a new custom form (from the default) and, without making any changes for visibility etc, all fields are still not shown.

Is there anything I need to change/reset/correct for custom forms at v11.5?


Best answer by Steve Exley 28 October 2022, 16:00

View original

3 replies

I’ve realised I should clarify this a little.  The changes are for the ‘My Assets’ form in assystNet.  There is a different item form for mobiles, applications, servers, and computers (i.e. desktop PCs and laptops).  Each one shows only the necessary details that would be relevant to the staff member it was assigned to.

Userlevel 2

Hi Steve

Will be going through this with a customer in training tomorrow so will check it out there for you



Userlevel 2

Hi Steve

Looks like Custom Fields are not displayed at all to Contact Users in the My Assets drill down.


Customiser View of the form of the item


Contact Users view of it

I will log an Incident for this